Archives

A sample text widget

Etiam pulvinar consectetur dolor sed malesuada. Ut convallis euismod dolor nec pretium. Nunc ut tristique massa.

Nam sodales mi vitae dolor ullamcorper et vulputate enim accumsan. Morbi orci magna, tincidunt vitae molestie nec, molestie at mi. Nulla nulla lorem, suscipit in posuere in, interdum non magna.

rpm依存性の欠如問題の解決のために

とにもかくにも,「依存性の欠如」エラーから抜け出さないと先には進めない.とりあえず,足りないモノを順番に入れていけばいいという至極簡単なセオリーを試してみる.エラーログを参考にすれば,「yum-1.0.3-6.0.7.x.legacy.noarch.rpm」のインストールには,「rpm-python 4.0.4以上」,「rpm 4.0.4以上」が必要らしい.じゃあ先にrpm-pythonをインストールしてみよう.

# rpm -Uvh http://download.fedoralegacy.org/redhat/7.3/os/i386/rpm-python-4.0.4-7x.18.i386.rpmhttp://download.fedoralegacy.org/redhat/7.3/os/i386/rpm-python-4.0.4-7x.18.i386.rpm を取得していますエラー: 依存性の欠如: rpm = 4.0.4は rpm-python-4.0.4-7x.18 に必要とされています popt = 1.6.4は rpm-python-4.0.4-7x.18 に必要とされています librpm-4.0.4.so は rpm-python-4.0.4-7x.18 に必要とされています librpmdb-4.0.4.so は rpm-python-4.0.4-7x.18 に必要とされています librpmio-4.0.4.so は rpm-python-4.0.4-7x.18 に必要とされています#

あぁぁ,やっぱりだめだったか・・・ これを見ると,popt 1.6.4というのが必要になりそうだ.そういえばこいつ,前回rpmを4.0.4にアップデートしようとしたときも表示されていたな.というわけで,fedoralegacyのサイトから,poptを無理矢理探し出した.どうせほかのrpmパッケージと同じディレクトリにあるんでしょ?と思ったら案の定ありましたぜ,旦那.

# rpm -Uvh http://download.fedoralegacy.org/redhat/7.3/os/i386/popt-1.6.4-7x.18.i386.rpmhttp://download.fedoralegacy.org/redhat/7.3/os/i386/popt-1.6.4-7x.18.i386.rpm を取得していますエラー: 依存性の欠如: popt = 1.6.3は rpm-4.0.3-1.03 に必要とされています popt = 1.6.3は rpm-devel-4.0.3-1.03 に必要とされています popt = […]